aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-airium/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-airium/APKBUILD')
-rw-r--r--community/py3-airium/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/py3-airium/APKBUILD b/community/py3-airium/APKBUILD
index d653d58962c..8c4d2f45c1f 100644
--- a/community/py3-airium/APKBUILD
+++ b/community/py3-airium/APKBUILD
@@ -1,28 +1,33 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-airium
-pkgver=0.2.3
-pkgrel=0
+pkgver=0.2.6
+pkgrel=1
pkgdesc="Bidirectional HTML to Python Translator"
url="https://gitlab.com/kamichal/airium"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="pytest"
-source="https://gitlab.com/kamichal/airium/-/archive/v$pkgver/airium-v$pkgver.tar.gz
- exclude-tests.patch"
+subpackages="$pkgname-pyc"
+source="https://gitlab.com/kamichal/airium/-/archive/v$pkgver/airium-v$pkgver.tar.gz"
builddir="$srcdir/airium-v$pkgver/"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+
# test_backward appears to be broken
# tests omitted from test_main_entry require network usage
# test_dependencies_message requires the package to be installed
- pytest \
+ .testenv/bin/python3 -m pytest \
--ignore tests/test_translation.py \
--deselect tests/test_boiler_hello.py::test_backward \
--deselect tests/test_main_entry.py::test_get_bad_content_type \
@@ -32,10 +37,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-2aa504fe899a8aead7674dc734688911d2d380df71d2f0413b89a70810ad557543e24a1f0268fc0d5829e70b0e88d08330239e4599fb9955953999d77f770fdb airium-v0.2.3.tar.gz
-493bd3d65bf34b80b149b95a4e449af7b2fd15b5500041ded3e44d4e19a9d0f82e10a139cde80119c516c81a4951d3d55eaa8fefb731d19a72a3595b8f517f99 exclude-tests.patch
+9c71ca65b33eba7b95351ac6947e39d2e354fa9a178c552a7d3d9cac4bc6397cd9b97fe8e91b9616451a8e4c68c0149ab5b7d75cd82baf3d891a7d6a345a784a airium-v0.2.6.tar.gz
"