aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ansicolor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ansicolor/APKBUILD')
-rw-r--r--community/py3-ansicolor/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/community/py3-ansicolor/APKBUILD b/community/py3-ansicolor/APKBUILD
index 2bf9fd4e35b..ea59368800e 100644
--- a/community/py3-ansicolor/APKBUILD
+++ b/community/py3-ansicolor/APKBUILD
@@ -2,9 +2,8 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-ansicolor
_pyname=ansicolor
-pkgver=0.2.6
-_commit=a5a5c31dc6de5c864a0c5684ae326972573a712b # Upstream didn't tag a new github release
-pkgrel=2
+pkgver=0.3.2
+pkgrel=4
pkgdesc="A library to produce ansi color output, highlighting and diffing"
url="https://github.com/numerodix/ansicolor"
arch="noarch"
@@ -13,9 +12,9 @@ depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
# no tests in artifact on PyPI
-source="$pkgname-$_commit.tar.gz::https://github.com/numerodix/ansicolor/archive/$_commit.tar.gz"
-
-builddir="$srcdir/$_pyname-$_commit"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/numerodix/ansicolor/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
build() {
python3 setup.py build
@@ -26,7 +25,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="fe886cdfc363de6d6a5abd35311a47fb15307eab7648d2532a575969887bec6abb4fbfdd7842f4289a1a1fb7772ed49750885fbaea91282fa2bd65c71725421d py3-ansicolor-a5a5c31dc6de5c864a0c5684ae326972573a712b.tar.gz"
+sha512sums="
+de1e1bc9d8a02accaa57a64e5d2ea1f510545b3ab83218c47c7a1861e8438862c222147c9dcab0fcb1ec4055dcee07d6cde6d7bfecfbf9ac55c3bb76ac0fb0ab py3-ansicolor-0.3.2.tar.gz
+"