aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-apipkg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-apipkg/APKBUILD')
-rw-r--r--community/py3-apipkg/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/py3-apipkg/APKBUILD b/community/py3-apipkg/APKBUILD
index 455a4d2c466..7200b9244dc 100644
--- a/community/py3-apipkg/APKBUILD
+++ b/community/py3-apipkg/APKBUILD
@@ -2,19 +2,17 @@
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
pkgname=py3-apipkg
_pkgname=apipkg
-pkgver=1.5
-pkgrel=5
+pkgver=2.1.0
+pkgrel=3
pkgdesc="apipkg: namespace control and lazy-import mechanism"
-# https://github.com/pytest-dev/apipkg/issues/17
-options="!check" # Known incompatibilites with pytest5
url="https://github.com/pytest-dev/apipkg"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools py3-setuptools_scm"
checkdepends="py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- 14.patch"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-apipkg" # Backwards compatibility
@@ -29,8 +27,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf apipkg-1.5.tar.gz
-96181be5cbc1bac03aa74347247fd4e97a8d2b3a93ebc8d412acdb3a02ae3792193234d18b0be626be2e76108c5803bd39ae995a98ecf324b8bc0e98a72bb7a8 14.patch"
+sha512sums="
+2281ffc999feddcc6073edcbb8512ded4240aaa1b472a81bbbd942da1601319ab6038387e08a2a14c962995ce94bab2e99f5a7747f8744e6af8d97abd076203b apipkg-2.1.0.tar.gz
+"