aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-arrow/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-arrow/APKBUILD')
-rw-r--r--community/py3-arrow/APKBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/community/py3-arrow/APKBUILD b/community/py3-arrow/APKBUILD
index 7a0c1cc3ae2..a236c9202a8 100644
--- a/community/py3-arrow/APKBUILD
+++ b/community/py3-arrow/APKBUILD
@@ -1,34 +1,45 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-arrow
-pkgver=0.17.0
+pkgver=1.3.0
pkgrel=1
pkgdesc="Python3 library to create and manipulate dates, times, and timestamps"
url="https://arrow.readthedocs.io/"
arch="noarch"
license="Apache-2.0"
depends="py3-dateutil"
-makedepends="py3-setuptools"
-checkdepends="py3-tz py3-simplejson py3-mock"
+makedepends="py3-flit-core py3-gpep517"
+checkdepends="
+ py3-pytest-cov
+ py3-pytest-mock
+ py3-simplejson
+ py3-tz
+ tzdata
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/a/arrow/arrow-$pkgver.tar.gz"
-options="!check" # Requires unpackaged 'chai'
builddir="$srcdir/arrow-$pkgver"
replaces="py-arrow" # for backwards compatibility
provides="py-arrow=$pkgver-r$pkgrel" # for backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # Requires unpackaged 'dateparser' module
- rm -f tests/factory_tests.py
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="30ab01c66ef1dfb7fb35dc8609ca19039fa3e37638ff0df681d0ffc9dbc832e9d3a577d9a45fc70ff3e74aacb6198b37e61ada22854572c57c27d7ecbef09caa arrow-0.17.0.tar.gz"
+sha512sums="
+f0725e75d1005e0177bb234b3d2523aaf9e882ec08b020f6b3737a3af27af3c8c031aee9dcba0332595845a09a0286d56662b77ddad8a6da928ba37201725239 arrow-1.3.0.tar.gz
+"