aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-arxiv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-arxiv/APKBUILD')
-rw-r--r--community/py3-arxiv/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/py3-arxiv/APKBUILD b/community/py3-arxiv/APKBUILD
new file mode 100644
index 00000000000..2cb66397b4d
--- /dev/null
+++ b/community/py3-arxiv/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+pkgname=py3-arxiv
+_pkgorig=arxiv.py
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Python wrapper for the arXiv API"
+url="https://github.com/lukasschwab/arxiv.py"
+arch="noarch"
+license="MIT"
+depends="python3 py3-feedparser py3-requests"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest-xdist py3-flake8"
+subpackages="$pkgname-pyc"
+source="https://github.com/lukasschwab/arxiv.py/archive/$pkgver/$_pkgorig-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgorig-$pkgver"
+# test domain 503's, uses net instead of a mock server
+options="!check"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+3ca1fa2a0bf5e2213d56572f3637785ac1d6b1b7b80304bc18d5fc5b7a0af6b1b48e8d0825d3c31bbb6bd68dbad532f0c5d06a481c7a3d38a36facefaf13cabd arxiv.py-2.1.0.tar.gz
+"