aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-asgiref/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-asgiref/APKBUILD')
-rw-r--r--community/py3-asgiref/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/community/py3-asgiref/APKBUILD b/community/py3-asgiref/APKBUILD
index 8ca9a6838a1..a8f5eea346f 100644
--- a/community/py3-asgiref/APKBUILD
+++ b/community/py3-asgiref/APKBUILD
@@ -1,29 +1,35 @@
# Contributor: Kaarle Ritvanen <kunkku@alpinelinux.org>
# Maintainer: Kaarle Ritvanen <kunkku@alpinelinux.org>
pkgname=py3-asgiref
-pkgver=3.4.1
+pkgver=3.8.1
pkgrel=1
pkgdesc="ASGI specs, helper code, and adapters"
url="https://github.com/django/asgiref/"
arch="noarch"
license="BSD-3-Clause"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
checkdepends="py3-pytest py3-pytest-asyncio"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/a/asgiref/asgiref-$pkgver.tar.gz"
builddir="$srcdir/asgiref-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" py.test-3
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --root "$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-af266fc3eac58c21f2ab3f66e522067388f9cf232b17344fb5afbc408c034e61a1cce02362ec5dc494985beef099800f75cf7de28dc057c45e4bcb973b0a6dbe asgiref-3.4.1.tar.gz
+3ef9ac2fcdce069cde96467abaa4a820c4eac19d40ce72e1afd0ca08279c00053a7e107966d766651def33a72a19c11559849b1032e89d62f544156590ef801d asgiref-3.8.1.tar.gz
"