aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aspectlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aspectlib/APKBUILD')
-rw-r--r--community/py3-aspectlib/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/py3-aspectlib/APKBUILD b/community/py3-aspectlib/APKBUILD
index 05a29759d3d..123ae4a00e4 100644
--- a/community/py3-aspectlib/APKBUILD
+++ b/community/py3-aspectlib/APKBUILD
@@ -1,24 +1,30 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer:
pkgname=py3-aspectlib
-pkgver=1.5.2
-pkgrel=1
+pkgver=2.0.0
+pkgrel=3
pkgdesc="aspect-oriented programming, monkey-patch and decorators library"
options="!check" # Missing process-tests
url="https://github.com/ionelmc/python-aspectlib"
arch="noarch"
license="BSD-2-Clause"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/a/aspectlib/aspectlib-$pkgver.tar.gz"
builddir="$srcdir/aspectlib-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/aspectlib*.whl
}
-sha512sums="999f7e893aee15d5bd89ae9aa45b82b639aae777ec5e946f7f0ee5aa7c2153d6a05ae0f1e95b7f5cdb4f4d12f188093479d9c50df6c7521003e83289cabb494b aspectlib-1.5.2.tar.gz"
+sha512sums="
+3611d3f887febae8a60df6ad5567437adaa2105e6622a7d9b543c02f593c9dee43002cd91b89f5d005fc70a8b197b5c568eefa3a0fdb6fc05665f4a1c5107316 aspectlib-2.0.0.tar.gz
+"