aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aspectlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aspectlib/APKBUILD')
-rw-r--r--community/py3-aspectlib/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/py3-aspectlib/APKBUILD b/community/py3-aspectlib/APKBUILD
index 7b1f162ae10..123ae4a00e4 100644
--- a/community/py3-aspectlib/APKBUILD
+++ b/community/py3-aspectlib/APKBUILD
@@ -1,24 +1,30 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer:
pkgname=py3-aspectlib
-pkgver=1.5.1
-pkgrel=0
+pkgver=2.0.0
+pkgrel=3
pkgdesc="aspect-oriented programming, monkey-patch and decorators library"
options="!check" # Missing process-tests
url="https://github.com/ionelmc/python-aspectlib"
arch="noarch"
license="BSD-2-Clause"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/a/aspectlib/aspectlib-$pkgver.tar.gz"
builddir="$srcdir/aspectlib-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/aspectlib*.whl
}
-sha512sums="8c6f5dd5bbb4517adae44715f8bacf7540feb897a50dacba237828377891bfde8355a8110ce3eb034ecaf6ef18d9e03da8cb1dfae11d04981590cc7d1c290622 aspectlib-1.5.1.tar.gz"
+sha512sums="
+3611d3f887febae8a60df6ad5567437adaa2105e6622a7d9b543c02f593c9dee43002cd91b89f5d005fc70a8b197b5c568eefa3a0fdb6fc05665f4a1c5107316 aspectlib-2.0.0.tar.gz
+"