aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-asttokens/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-asttokens/APKBUILD')
-rw-r--r--community/py3-asttokens/APKBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/community/py3-asttokens/APKBUILD b/community/py3-asttokens/APKBUILD
index bcbedbe4e44..05bc28e630d 100644
--- a/community/py3-asttokens/APKBUILD
+++ b/community/py3-asttokens/APKBUILD
@@ -1,35 +1,40 @@
# Contributor: Justin Berthault <justin.berthault@zaclys.net>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=py3-asttokens
-pkgver=2.0.5
-pkgrel=0
+pkgver=2.4.1
+pkgrel=1
pkgdesc="Annotate AST trees with source code positions"
url="https://github.com/gristlabs/asttokens"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-six"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools_scm py3-wheel"
checkdepends="py3-astroid py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/a/asttokens/asttokens-$pkgver.tar.gz
+ fix-setuptools-deprecation.patch
"
builddir="$srcdir/"asttokens-$pkgver
-prepare() {
- default_prepare
-
- sed -e '/setuptools_scm/d' -i setup.cfg
-}
-
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- env PYTHONPATH="$PWD/build/lib" py.test-3 -v
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="60b323be72de75b2d612e7d602a202fae46559f0842624d38ff0a22376573c3e4885ad2cece04314ef7f230f8e47ae6fc8d9f39a6bdacc1c74961a5158abd463 asttokens-2.0.5.tar.gz"
+sha512sums="
+5b60293e40afc42baab346b2367485f2a4dda6210bbbda53e3080ce86b05c96f928ad1eea00a2b81a2afcce626a18c8166add26bbf8b320d4f71b6fc4aa9083a asttokens-2.4.1.tar.gz
+967e339c12e4be1bb9e228055697d29ed1dd7d74ef01479befe64c755533f4df077dc6cdb4c42f191e46c4e882dc85de546c7e85012f8cc6a808e5f22f04b330 fix-setuptools-deprecation.patch
+"