aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-augeas/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-augeas/APKBUILD')
-rw-r--r--community/py3-augeas/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/py3-augeas/APKBUILD b/community/py3-augeas/APKBUILD
index 6df37700d62..12c0d9de19d 100644
--- a/community/py3-augeas/APKBUILD
+++ b/community/py3-augeas/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-augeas
_pkgname=python-augeas
pkgver=1.1.0
-pkgrel=1
+pkgrel=6
pkgdesc="Pure python bindings for augeas"
-url="https://pypi.python.org/pypi/python-augeas"
+url="https://pypi.org/project/python-augeas"
arch="noarch"
license="LGPL-2.1-or-later"
depends="augeas-libs py3-cffi python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
dlopen-libc-explicitly.patch
"
@@ -28,7 +29,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/test
}