aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-authlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-authlib/APKBUILD')
-rw-r--r--community/py3-authlib/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/py3-authlib/APKBUILD b/community/py3-authlib/APKBUILD
index 492cd138f2a..3c3829d2e7a 100644
--- a/community/py3-authlib/APKBUILD
+++ b/community/py3-authlib/APKBUILD
@@ -1,21 +1,24 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer:
pkgname=py3-authlib
-pkgver=0.15.5
-pkgrel=1
-pkgdesc="The ultimate Python library in building OAuth and OpenID Connect servers"
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Python library for building OAuth and OpenID Connect servers"
url="https://github.com/lepture/authlib"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-cryptography"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
#checkdepends="py3-django py3-flask-sqlalchemy"
options="!check" # missing deps: py3-httpx, py3-starlette,py3-pytest-django
+subpackages="$pkgname-pyc"
source="https://pypi.io/packages/source/A/Authlib/Authlib-$pkgver.tar.gz"
builddir="$srcdir/Authlib-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -23,9 +26,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/Authlib*.whl
}
sha512sums="
-72655afd0039fb6baed9179fb6d56c2a439847ce4b44a58e885e43bb2bdc4111147a592a1d027a093e3e851b2b1f89663028d745c9a6dd02bdd046f70565b5a3 Authlib-0.15.5.tar.gz
+86cb56123445b27fccb410d4440618378a6235d3d07b53a0f0e9ca3b409a3844aa1eca776124082e3f7dbb33d00385eb5146793545fc7c5956b0be4a18edb3a6 Authlib-1.3.0.tar.gz
"