aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-autobahn/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-autobahn/APKBUILD')
-rw-r--r--community/py3-autobahn/APKBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/community/py3-autobahn/APKBUILD b/community/py3-autobahn/APKBUILD
index e88922e0292..de580323154 100644
--- a/community/py3-autobahn/APKBUILD
+++ b/community/py3-autobahn/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-autobahn
-pkgver=21.3.1
-pkgrel=2
+pkgver=23.6.2
+pkgrel=1
pkgdesc="WebSocket client & server library, WAMP real-time framework"
url="https://crossbar.io/autobahn/"
arch="noarch"
@@ -12,26 +12,35 @@ depends="
py3-twisted
py3-sphinxcontrib-images
py3-pynacl
- python3
"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz"
options="!check" # Fail to run https://github.com/crossbario/autobahn-python/issues/1117
builddir="$srcdir/autobahn-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- find "$pkgdir" -name "test" -type d -exec rm -r {} +
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="dd6bf6eba6f2880860c6fa42e3925bb15d36bfb9d2354ddeb0165972848e81a308723b7f9dcd6ec3426b6286f71cb2da453590810e5d891523d92acf9fd64c52 autobahn-21.3.1.tar.gz"
+sha512sums="
+5935203277d17aab3f80e6edf700ff173fe7e23622b9d2617f91e080f56b078f947f907289f008b5eb21b1346142274616baad4a36629f49dafe409d6fdb931a autobahn-23.6.2.tar.gz
+"