aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-automat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-automat/APKBUILD')
-rw-r--r--community/py3-automat/APKBUILD30
1 files changed, 20 insertions, 10 deletions
diff --git a/community/py3-automat/APKBUILD b/community/py3-automat/APKBUILD
index 82f8e049b76..640dade614c 100644
--- a/community/py3-automat/APKBUILD
+++ b/community/py3-automat/APKBUILD
@@ -2,30 +2,40 @@
# Contributor: Tiago Ilieve <tiago.myhro@gmail.com>
# Maintainer: Tiago Ilieve <tiago.myhro@gmail.com>
pkgname=py3-automat
-_pkgname=Automat
-pkgver=0.7.0
-pkgrel=2
+pkgver=22.10.0
+pkgrel=3
pkgdesc="Self-service finite-state machines for the programmer on the go"
url="https://automat.readthedocs.io/"
arch="noarch"
license="MIT"
depends="py3-attrs py3-six"
-makedepends="py3-setuptools py3-incremental pytest py3-graphviz py3-twisted"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+makedepends="py3-setuptools py3-setuptools_scm py3-wheel"
+checkdepends="py3-pytest py3-pluggy"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/glyph/automat/archive/v$pkgver.tar.gz"
+builddir="$srcdir/automat-$pkgver"
replaces="py-automat" # Backwards compatibility
-provides="py-automat=$pkver-r$pkgrel" # Backwards compatibility
+provides="py-automat=$pkgver-r$pkgrel" # Backwards compatibility
+
+prepare() {
+ default_prepare
+}
build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
python3 setup.py build
}
check() {
- py.test-3 automat/_test
+ pytest automat/_test
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="a6f307d312a3ceb721071b5212297c73d2306894b5fafd39265578041a2859bd6f041ac43a654bdda4175a70a4e90e0db1ee35cd43fa620cd5c594b5d1988a74 Automat-0.7.0.tar.gz"
+
+sha512sums="
+16caea66a8621b7d50e68e94007085218ec40ae0f57599d5076ed1915d4a2ebabd2da66659ba70acb9c6d30bc354bcd6126f913af0c0a005db305ca0c203481d py3-automat-22.10.0.tar.gz
+"