aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-automat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-automat/APKBUILD')
-rw-r--r--community/py3-automat/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/py3-automat/APKBUILD b/community/py3-automat/APKBUILD
index 488ee637f17..640dade614c 100644
--- a/community/py3-automat/APKBUILD
+++ b/community/py3-automat/APKBUILD
@@ -2,15 +2,16 @@
# Contributor: Tiago Ilieve <tiago.myhro@gmail.com>
# Maintainer: Tiago Ilieve <tiago.myhro@gmail.com>
pkgname=py3-automat
-pkgver=20.2.0
-pkgrel=0
+pkgver=22.10.0
+pkgrel=3
pkgdesc="Self-service finite-state machines for the programmer on the go"
url="https://automat.readthedocs.io/"
arch="noarch"
license="MIT"
depends="py3-attrs py3-six"
-makedepends="py3-setuptools py3-setuptools_scm"
+makedepends="py3-setuptools py3-setuptools_scm py3-wheel"
checkdepends="py3-pytest py3-pluggy"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/glyph/automat/archive/v$pkgver.tar.gz"
builddir="$srcdir/automat-$pkgver"
@@ -19,20 +20,22 @@ provides="py-automat=$pkgver-r$pkgrel" # Backwards compatibility
prepare() {
default_prepare
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
}
build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
python3 setup.py build
}
check() {
- py.test-3 automat/_test
+ pytest automat/_test
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="ccba3e82f589fedb1f83dfb37a6a42b51a78d8c3e6fea22c9518135ff194f5f70e2f9c5f0eab50b6e116dae92c94754aac8dbf0e670a59015c916991736b4076 py3-automat-20.2.0.tar.gz"
+sha512sums="
+16caea66a8621b7d50e68e94007085218ec40ae0f57599d5076ed1915d4a2ebabd2da66659ba70acb9c6d30bc354bcd6126f913af0c0a005db305ca0c203481d py3-automat-22.10.0.tar.gz
+"