aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-automat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-automat/APKBUILD')
-rw-r--r--community/py3-automat/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/py3-automat/APKBUILD b/community/py3-automat/APKBUILD
index 488ee637f17..3e4c517fbac 100644
--- a/community/py3-automat/APKBUILD
+++ b/community/py3-automat/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Tiago Ilieve <tiago.myhro@gmail.com>
pkgname=py3-automat
pkgver=20.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Self-service finite-state machines for the programmer on the go"
url="https://automat.readthedocs.io/"
arch="noarch"
@@ -11,7 +11,8 @@ license="MIT"
depends="py3-attrs py3-six"
makedepends="py3-setuptools py3-setuptools_scm"
checkdepends="py3-pytest py3-pluggy"
-source="$pkgname-$pkgver.tar.gz::https://github.com/glyph/automat/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/glyph/automat/archive/v$pkgver.tar.gz
+ disable-m2r.patch"
builddir="$srcdir/automat-$pkgver"
replaces="py-automat" # Backwards compatibility
@@ -19,11 +20,10 @@ provides="py-automat=$pkgver-r$pkgrel" # Backwards compatibility
prepare() {
default_prepare
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
}
build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
python3 setup.py build
}
@@ -32,7 +32,9 @@ check() {
}
package() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="ccba3e82f589fedb1f83dfb37a6a42b51a78d8c3e6fea22c9518135ff194f5f70e2f9c5f0eab50b6e116dae92c94754aac8dbf0e670a59015c916991736b4076 py3-automat-20.2.0.tar.gz"
+sha512sums="ccba3e82f589fedb1f83dfb37a6a42b51a78d8c3e6fea22c9518135ff194f5f70e2f9c5f0eab50b6e116dae92c94754aac8dbf0e670a59015c916991736b4076 py3-automat-20.2.0.tar.gz
+405c2206b1b4905d51ba5115edbd19ee4c8b97144ceda3495cc696c2d17ba71401c0f2826e38934d74a83bc3186562c1a65a8599bddfb49eb32ed2fb7cd16d01 disable-m2r.patch"