aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-autopep8/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-autopep8/APKBUILD')
-rw-r--r--community/py3-autopep8/APKBUILD30
1 files changed, 20 insertions, 10 deletions
diff --git a/community/py3-autopep8/APKBUILD b/community/py3-autopep8/APKBUILD
index 4fd90428ea5..cb637aa006d 100644
--- a/community/py3-autopep8/APKBUILD
+++ b/community/py3-autopep8/APKBUILD
@@ -1,34 +1,44 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-autopep8
-pkgver=1.6.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="automatically format your Python code to conform to the PEP 8 style guide"
-url="https://pypi.python.org/pypi/autopep8/"
+url="https://pypi.org/project/autopep8/"
arch="noarch"
license="MIT"
depends="
py3-pycodestyle
- py3-toml
- python3
+ py3-tomli
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
"
-makedepends="py3-setuptools"
checkdepends="py3-pytest"
-source="https://github.com/hhatto/autopep8/archive/v$pkgver/autopep8-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hhatto/autopep8/archive/refs/tags/v$pkgver.tar.gz"
+#options="!check" # fail with py3.11
builddir="$srcdir/autopep8-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-4e95c46ed8542de7dfdfb1d5e73e8551df2fce8f5371e34580359285441288abdaefde1edc4f2c9701c2883fd189a8448f761b3db0a23ea425db71f8af0ded53 autopep8-1.6.0.tar.gz
+90f5adcb5e3fb1cde8aa961d15db5b3a6be0433f865aa5de548283d0a7c2121a2436629b4c6f49fd8187daf4bcbf25bc4728ceaf76d7a3c66da0f6c41b9ee894 py3-autopep8-2.1.0.tar.gz
"