aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-autopep8/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-autopep8/APKBUILD')
-rw-r--r--community/py3-autopep8/APKBUILD37
1 files changed, 27 insertions, 10 deletions
diff --git a/community/py3-autopep8/APKBUILD b/community/py3-autopep8/APKBUILD
index adcecbf98e9..cb637aa006d 100644
--- a/community/py3-autopep8/APKBUILD
+++ b/community/py3-autopep8/APKBUILD
@@ -1,27 +1,44 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-autopep8
-pkgver=1.5.4
-pkgrel=0
-pkgdesc="A tool that automatically formats Python code to conform to the PEP 8 style guide"
-url="https://pypi.python.org/pypi/autopep8/"
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="automatically format your Python code to conform to the PEP 8 style guide"
+url="https://pypi.org/project/autopep8/"
arch="noarch"
license="MIT"
-depends="python3 py3-setuptools py3-pycodestyle py3-toml"
+depends="
+ py3-pycodestyle
+ py3-tomli
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest"
-source="https://github.com/hhatto/autopep8/archive/v$pkgver/autopep8-$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hhatto/autopep8/archive/refs/tags/v$pkgver.tar.gz"
+#options="!check" # fail with py3.11
builddir="$srcdir/autopep8-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="f830ca310616e1a151b3d7c78b61ec6d33db19c123d673729dc14ebd858e1f150d9405081a1fab30fbeac3ef59a5c216f1dd2a120623e7f3deb2770cc1854ad1 autopep8-1.5.4.tar.gz"
+sha512sums="
+90f5adcb5e3fb1cde8aa961d15db5b3a6be0433f865aa5de548283d0a7c2121a2436629b4c6f49fd8187daf4bcbf25bc4728ceaf76d7a3c66da0f6c41b9ee894 py3-autopep8-2.1.0.tar.gz
+"