aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-beautifulsoup4/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-beautifulsoup4/APKBUILD')
-rw-r--r--community/py3-beautifulsoup4/APKBUILD35
1 files changed, 21 insertions, 14 deletions
diff --git a/community/py3-beautifulsoup4/APKBUILD b/community/py3-beautifulsoup4/APKBUILD
index 11c32e9b2ac..cd08895feab 100644
--- a/community/py3-beautifulsoup4/APKBUILD
+++ b/community/py3-beautifulsoup4/APKBUILD
@@ -1,36 +1,43 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: fossdd <fossdd@pwned.life>
+# Maintainer: fossdd <fossdd@pwned.life>
pkgname=py3-beautifulsoup4
_pkgname=beautifulsoup4
-pkgver=4.9.3
-pkgrel=1
+pkgver=4.12.3
+pkgrel=2
pkgdesc="A Python HTML/XML parser"
-url="http://www.crummy.com/software/BeautifulSoup/index.html"
+url="https://www.crummy.com/software/BeautifulSoup/index.html"
arch="noarch"
license="MIT"
depends="python3 py3-soupsieve"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-hatchling
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/beautifulsoup4/beautifulsoup4-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-beautifulsoup4" # Backwards compatibility
provides="py-beautifulsoup4=$pkgver-r$pkgrel" # Backwards compatibility
-case "$CARCH" in
-mips*) options="!check" ;;
-esac
-
build() {
- 2to3 -w --no-diff bs4
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m unittest discover -s bs4
+ python3 -m pytest -s bs4
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ rm -r "$pkgdir"/usr/lib/python3*/site-packages/bs4/tests
}
-sha512sums="e3cb6258bd7c51f12128fa8ee5948fb3566163ae233fac2dda21bab7772ab8dbb384d920b0ea138ef9921307b48f89cee3a9bf6111dfc8903d917ee7af365f34 beautifulsoup4-4.9.3.tar.gz"
+sha512sums="
+b5b6cc9f64a97fa52b9a2ee1265aa215db476e705d3d79e49301de7e8d36c56c96924cb440eec0715f7ec75c5ddf4c1ade9d6cef7cdc9bf9e37125ac6eb50837 beautifulsoup4-4.12.3.tar.gz
+"