aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-betamax/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-betamax/APKBUILD')
-rw-r--r--community/py3-betamax/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/community/py3-betamax/APKBUILD b/community/py3-betamax/APKBUILD
index 7364a824209..27e319cf1ce 100644
--- a/community/py3-betamax/APKBUILD
+++ b/community/py3-betamax/APKBUILD
@@ -1,32 +1,36 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-betamax
-pkgver=0.8.1
-pkgrel=2
+pkgver=0.9.0
+pkgrel=1
pkgdesc="VCR imitation designed only for python-requests"
-options="!check" # 3 Tests fail, tests require internet
+options="!check" # 1 Test fails, tests require internet
url="https://github.com/betamaxpy/betamax"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-requests"
-makedepends="py3-setuptools py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://github.com/betamaxpy/betamax/archive/$pkgver.tar.gz
- https://github.com/betamaxpy/betamax/commit/165cc321f2b9839418269e9493b03eb2e43f7ddf.patch
- tests-disable-broken-assertion.patch
- "
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/betamaxpy/betamax/archive/$pkgver.tar.gz"
builddir="$srcdir/betamax-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="3888aa5f1e249faf496a32c03fb7d37096d7bbde573048c2ff3d1ba0fa03ebaeb4ff4e72191478da5f1a04d813204e31d3897469bd5f5eea4c5db2c72aae1374 py3-betamax-0.8.1.tar.gz
-258bd6729286dc9374829308c23cca73ea640c4597ca8747ebb8281bcf7723bba3dfee5b55cadff0459e8dc4511d85228d37911e981859dd0af55a3753ae9e22 165cc321f2b9839418269e9493b03eb2e43f7ddf.patch
-d7039add209472045f2b7c4326c0d1234ae86b3e28a7ae3705ba695fd54783b1639b6c59781df1034dc777c3bc2cd0615a2227b0e7eafec890b707cabe0fa617 tests-disable-broken-assertion.patch"
+sha512sums="
+6a85f21dd7ccd0d53e6c87ff4f159d295d40729098c13c435c1715252e4cbbeabb82e6347e84a16094f13a1a0249dd1c067ddc82fd36c292913ecbdb22148371 py3-betamax-0.9.0.tar.gz
+"