aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-botocore/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-botocore/APKBUILD')
-rw-r--r--community/py3-botocore/APKBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/community/py3-botocore/APKBUILD b/community/py3-botocore/APKBUILD
index 9e2f9fd46ca..f8df954dec6 100644
--- a/community/py3-botocore/APKBUILD
+++ b/community/py3-botocore/APKBUILD
@@ -2,32 +2,42 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=py3-botocore
# Verify required version from py3-boto3 on this package before upgrading
-pkgver=1.20.105
-pkgrel=0
+pkgver=1.31.12
+pkgrel=1
pkgdesc="The low-level, core functionality of Boto3"
url="https://github.com/boto/botocore"
arch="noarch"
license="Apache-2.0"
-depends="py3-dateutil<3.0 py3-docutils py3-jmespath<1.0.0 py3-urllib3<1.27"
-makedepends="py3-setuptools"
+depends="
+ py3-certifi
+ py3-dateutil
+ py3-jmespath
+ py3-urllib3
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/b/botocore/botocore-$pkgver.tar.gz"
builddir="$srcdir/botocore-$pkgver"
+options="!check" # take way too long
replaces=py-botocore # Backwards compatibility
provides=py-botocore=$pkgver-r$pkgrel # Backwards compatibility
build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py check
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-72267620e4ecb7e4e4fa446b8f5c0b42d2e0af372f9e8bcfea123e5d8a6f4638102d57a9eb9f3c6f2358c6c2b36e727552c0b350b07f95a79292fb3c2cf4dd99 botocore-1.20.105.tar.gz
+b8354f2d531bfda166155e111abc61640293a175d88b814aec9ff0e1d6cb3ebd90806c0027787f847ad3ddd6c9f835256a4ba0b74e908f3372e391282724a1cb botocore-1.31.12.tar.gz
"