aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-bottle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-bottle/APKBUILD')
-rw-r--r--community/py3-bottle/APKBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/community/py3-bottle/APKBUILD b/community/py3-bottle/APKBUILD
index 7e259d6b2e9..2b878cdfa32 100644
--- a/community/py3-bottle/APKBUILD
+++ b/community/py3-bottle/APKBUILD
@@ -2,15 +2,20 @@
# Maintainer: Paul Kilar <pkilar@gmail.com>
pkgname=py3-bottle
_pkgname=bottle
-pkgver=0.12.21
-pkgrel=0
+pkgver=0.12.25
+pkgrel=2
pkgdesc="fast, simple and lightweight WSGI micro web-framework"
options="!check" # failures=1
url="https://bottlepy.org/docs/dev"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -22,17 +27,22 @@ replaces="py-bottle" # Backwards compatibility
provides="py-bottle=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 test/testall.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m unittest discover test
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-3d621f6684f439a4a5718ad25e8b45eb0d1100cd565ec5b797adf67141e01d835cde671e687f5515cb6eab69bb465e9c7d004131634609266c2e1b69b0adbf43 bottle-0.12.21.tar.gz
+14b8ed1ffd58f9667d451872ccf73a6f4bf8f7ffb9329f55314f90c770630cfe3f9956f786bcc7fd5f67fde22d14961952969af405912ebe71f019ca6599c975 bottle-0.12.25.tar.gz
"