aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-breathe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-breathe/APKBUILD')
-rw-r--r--community/py3-breathe/APKBUILD27
1 files changed, 19 insertions, 8 deletions
diff --git a/community/py3-breathe/APKBUILD b/community/py3-breathe/APKBUILD
index 4907913c29c..a368581c7bf 100644
--- a/community/py3-breathe/APKBUILD
+++ b/community/py3-breathe/APKBUILD
@@ -2,30 +2,41 @@
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-breathe
_pkgname=breathe
-pkgver=4.33.1
-pkgrel=1
+pkgver=4.35.0
+pkgrel=3
pkgdesc="ReStructuredText and Sphinx bridge to Doxygen"
url="https://breathe.readthedocs.org/"
arch="noarch"
license="BSD-3-Clause-Clear"
depends="python3 py3-sphinx doxygen"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://github.com/michaeljones/breathe/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/breathe-doc/breathe/archive/v$pkgver.tar.gz
+ test_renderer.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- make dev-test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-770c0fd8eaca798c84cbbf138b0b4b1a348e2010cedf5efec085fff348e8b0e548ccbe160ecb112709929ee0cf8fd0d977c5032ae03f74cd39f4bb2ae1d5f14b py3-breathe-4.33.1.tar.gz
+76e36fceb89c21e2c62471a37b856f8e7077f946ca8ebffdd068297d7d447ba4f42f8f9d91e231f7a181d7dba2cb8650479f35f8bef342184e5ccbd3dd951f91 py3-breathe-4.35.0.tar.gz
+daf9aec441cd3708978b6cc292ec46cde28b4df441ae5b8c9514200f647bbb60010e50125665a2723e467a48123ac991d36ddaf07d59b34fcb680a3d820cded7 test_renderer.patch
"