aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-brotlipy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-brotlipy/APKBUILD')
-rw-r--r--community/py3-brotlipy/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/py3-brotlipy/APKBUILD b/community/py3-brotlipy/APKBUILD
index 9c0db50998a..a59b22c4ad5 100644
--- a/community/py3-brotlipy/APKBUILD
+++ b/community/py3-brotlipy/APKBUILD
@@ -3,15 +3,16 @@
pkgname=py3-brotlipy
_pkgname=brotlipy
pkgver=0.7.0
-pkgrel=2
+pkgrel=6
pkgdesc="Python bindings for the Brotli compression library"
options="!check" # Tests fail with new pytest
-url="https://github.com/python-hyper/brotlipy"
+url="https://github.com/python-hyper/brotlicffi"
arch="all"
license="MIT"
depends="python3"
makedepends="py3-setuptools python3-dev py3-cffi"
checkdepends="py3-pytest py3-hypothesis py3-pytest-runner"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/brotlipy-$pkgver"
@@ -24,7 +25,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="2a01e5b2d217043f13316afc4f54569c5dff76d31c296d4be563a5851195380ab80a33a3035ca95effdebffb45806fb9a431a181bba6f9af205b7f5576937268 brotlipy-0.7.0.tar.gz"
+sha512sums="
+2a01e5b2d217043f13316afc4f54569c5dff76d31c296d4be563a5851195380ab80a33a3035ca95effdebffb45806fb9a431a181bba6f9af205b7f5576937268 brotlipy-0.7.0.tar.gz
+"