aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cachetools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cachetools/APKBUILD')
-rw-r--r--community/py3-cachetools/APKBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/community/py3-cachetools/APKBUILD b/community/py3-cachetools/APKBUILD
index 37ca828c548..8ed1f00305b 100644
--- a/community/py3-cachetools/APKBUILD
+++ b/community/py3-cachetools/APKBUILD
@@ -2,28 +2,40 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py3-cachetools
_pyname=cachetools
-pkgver=4.1.1
-pkgrel=0
+pkgver=5.3.3
+pkgrel=1
pkgdesc="Extensible memoizing collections and decorators"
url="https://github.com/tkem/cachetools"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/tkem/cachetools/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest .
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="c5d8a304defd0d9cd767b4e00f70c8df31067003afec43459db239d9c59c582fe6454c2956f5092e15b464bf53adf33a1214c1d03bd2dca610b112b9a63b7a06 py3-cachetools-4.1.1.tar.gz"
+sha512sums="
+835bd0a0cc95fc80a184a8aad0a2bae71702462c9d094300c0854f9ce4039c70862b1fa0cddd774860f3f5cceeee4dd8f711bec47aff252384b36072998d03f0 py3-cachetools-5.3.3.tar.gz
+"