aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-capturer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-capturer/APKBUILD')
-rw-r--r--community/py3-capturer/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-capturer/APKBUILD b/community/py3-capturer/APKBUILD
index 168719e580a..acc975c3101 100644
--- a/community/py3-capturer/APKBUILD
+++ b/community/py3-capturer/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-capturer
pkgver=3.0
-pkgrel=0
+pkgrel=4
pkgdesc="Easily capture stdout/stderr of the current process and subprocesses"
url="https://capturer.readthedocs.io/en/latest/"
arch="noarch"
@@ -12,6 +12,7 @@ options="!check"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/c/capturer/capturer-$pkgver.tar.gz"
builddir="$srcdir/capturer-$pkgver"
@@ -24,7 +25,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
find "$pkgdir" -name "*tests*" -delete
}