aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-characteristic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-characteristic/APKBUILD')
-rw-r--r--community/py3-characteristic/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/py3-characteristic/APKBUILD b/community/py3-characteristic/APKBUILD
index 66c8c1e339d..058d8773c0a 100644
--- a/community/py3-characteristic/APKBUILD
+++ b/community/py3-characteristic/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-characteristic
_pkgname=characteristic
pkgver=14.3.0
-pkgrel=6
+pkgrel=10
pkgdesc="Service identity verification for pyOpenSSL"
url="https://characteristic.readthedocs.io/en/stable/"
arch="noarch"
@@ -11,6 +11,7 @@ license="MIT"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -32,8 +33,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-
sha512sums="e13a86f453cd3688a74188005b82a661a9c73d9f0408d9afe9e0575e69ffe87a5327f51e2c16a9c0a653b738e7c014d5aa08e353835f0aca7897714b7ae56e83 characteristic-14.3.0.tar.gz"