aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cherrypy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cherrypy/APKBUILD')
-rw-r--r--community/py3-cherrypy/APKBUILD32
1 files changed, 21 insertions, 11 deletions
diff --git a/community/py3-cherrypy/APKBUILD b/community/py3-cherrypy/APKBUILD
index 12561a41b36..840df9112af 100644
--- a/community/py3-cherrypy/APKBUILD
+++ b/community/py3-cherrypy/APKBUILD
@@ -4,37 +4,46 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-cherrypy
-pkgver=18.6.1
-pkgrel=5
+_pkgreal=CherryPy
+pkgver=18.9.0
+pkgrel=1
pkgdesc="A pythonic, object-oriented web development framework"
url="https://cherrypy.dev/"
arch="noarch"
license="BSD-3-Clause"
depends="py3-cheroot py3-jaraco.collections py3-portend py3-zc.lockfile"
-# py3-setuptools_scm is needed to set python module version
-makedepends="py3-setuptools py3-setuptools_scm"
+makedepends="py3-gpep517 py3-installer py3-setuptools py3-setuptools_scm py3-wheel"
checkdepends="py3-cheroot-tests py3-path py3-pytest py3-pytest-cov py3-requests-toolbelt py3-tz"
-subpackages="$pkgname-tutorial"
+subpackages="$pkgname-tutorial $pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/C/CherryPy/CherryPy-$pkgver.tar.gz
+ no-warn-fail.patch
tests.patch
test_timeout.patch
gziptest.patch
"
-builddir="$srcdir"/CherryPy-$pkgver
+builddir="$srcdir/$_pkgreal-$pkgver"
replaces="py-cherrypy" # Backwards compatibility
provides="py-cherrypy=$pkgver-r$pkgrel" # Backwards compatibility
+options="!check" # take forever
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest -W ignore::DeprecationWarning -W ignore:"unclosed ":ResourceWarning \
- --deselect=cherrypy/test/test_session.py::MemcachedSessionTest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -W ignore::DeprecationWarning -W ignore:"unclosed ":ResourceWarning \
+ --deselect=cherrypy/test/test_session.py::MemcachedSessionTest \
+ --deselect=cherrypy/test/test_caching.py::CacheTest::test_antistampede \
+ --deselect=cherrypy/test/test_static.py::StaticTest::test_file_stream
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/cherrypy/test
}
@@ -45,7 +54,8 @@ tutorial() {
}
sha512sums="
-186a0992a443e1ffc1a2924b3351dcb0e6cc6c88b39ac32330d6365fe1b0a35c2008a3a18e1a57f61ffd1901ea6134333bb6288024d8ffbb1fd8e8dcd3145007 CherryPy-18.6.1.tar.gz
+ed2beacedd3417214f45e59567f2a1faf5964745a545360db2f61251a39f50f2a833745832a2c900673029d98062f7e1813db6c342585f8d2bbae0be423edb3a CherryPy-18.9.0.tar.gz
+fd3a58817a0d36d93deb46fea820c0422bf88159d18961b0d47d39124871b34fda2e2bec8416bfc6cc1a16af0160b5fc491bdf873b75d319716efa2dc19b47b8 no-warn-fail.patch
64d5e51822fca9045f76894a4e5322b80b2c7826eea21fc97e81bffe419a5f940481b807dad70eee53e4a31bc3598ed10252e7ae97c1d7dcb7ba4085ab3298d6 tests.patch
5d926f538f456e6b58de4c02da51bfa327c71a506bb5fc251303aa4838b311179324245401ec9c5af3043d7d31a3ee211d26344b12c82fc9ed36d666344b45da test_timeout.patch
cc0384514a3cef41cbfcc441ba66a26feaf71cbd7ab092c8281782dfdfdccaa20cf5facf414e97cb88dd8e7c377067c8b6afdef4f71f22dee4c60db6a02c483b gziptest.patch