aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-circuitbreaker/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-circuitbreaker/APKBUILD')
-rw-r--r--community/py3-circuitbreaker/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/py3-circuitbreaker/APKBUILD b/community/py3-circuitbreaker/APKBUILD
index 9c7ca6ea3a1..6755f90eda5 100644
--- a/community/py3-circuitbreaker/APKBUILD
+++ b/community/py3-circuitbreaker/APKBUILD
@@ -1,30 +1,36 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-circuitbreaker
-pkgver=1.3.2
-pkgrel=0
+pkgver=2.0.0
+pkgrel=1
pkgdesc="Python Circuit Breaker pattern implementation"
-url="https://github.com/jaraco/jaraco.collections"
+url="https://github.com/fabfuel/circuitbreaker"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-mock py3-pytest"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-pytest-mock py3-pytest-tornasync"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/c/circuitbreaker/circuitbreaker-$pkgver.tar.gz"
builddir="$srcdir/circuitbreaker-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-d739272ab36e224d69227d77638a3531ef1a50dd1f691f17c6c9bc7a938b4a70cedd77a6fd8e37c131c75878b4a408511622779c78b72ad308a97d6df789a962 circuitbreaker-1.3.2.tar.gz
+f719182c36bf72813a3cf497c2eba01d3dba549bcec11bd2e95bd4b9007536c7f7cf2329051dee2a4139d22f13fe7f13132d975b92d6de1b86be044ef6f45258 circuitbreaker-2.0.0.tar.gz
"