aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cleo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cleo/APKBUILD')
-rw-r--r--community/py3-cleo/APKBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/community/py3-cleo/APKBUILD b/community/py3-cleo/APKBUILD
index 01e7229af10..d6ab35e8f4b 100644
--- a/community/py3-cleo/APKBUILD
+++ b/community/py3-cleo/APKBUILD
@@ -2,36 +2,35 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-cleo
-_realname=cleo
-pkgver=0.8.1
-pkgrel=4
+pkgver=2.1.0
+pkgrel=1
pkgdesc="Python3 library to create beautiful and testable command-line interfaces"
-url="https://github.com/sdispater/cleo"
+url="https://github.com/python-poetry/cleo"
arch="noarch"
license="MIT"
-depends="python3 py3-pastel py3-pylev py3-clikit"
+depends="python3 py3-crashtest py3-rapidfuzz"
+makedepends="py3-gpep517 py3-poetry-core"
checkdepends="py3-pytest py3-pytest-mock"
-makedepends="py3-build py3-installer py3-poetry-core"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sdispater/cleo/archive/refs/tags/$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/python-poetry/cleo/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/cleo-$pkgver"
build() {
- # XXX: hack for poetry to not ignore files
- GIT_DIR=. python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m installer -d testenv \
- dist/cleo-$pkgver-py2.py3-none-any.whl
- local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
- PYTHONPATH="$PWD/testenv/$sitedir" python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 -m installer -d "$pkgdir" \
- dist/cleo-$pkgver-py2.py3-none-any.whl
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-9cd470063db9866a526f0bb8619d772c585377d5b1a662e0f94bad9fb9c853598b176444ca1ac0fadec82992196c471646504d6a28d4dcd1171433b8d160be9c py3-cleo-0.8.1.tar.gz
+e73a4c02470052f0f602fae8b5bf7073f3342d0816074398b19f0fb25caddda51b6d2fcb9ef57026638d0dc8861a2b5142d87551b105cefa5e54426e4aa1225c py3-cleo-2.1.0.tar.gz
"