aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-click/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-click/APKBUILD')
-rw-r--r--community/py3-click/APKBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/community/py3-click/APKBUILD b/community/py3-click/APKBUILD
index d88e3107c11..2d92ac2e244 100644
--- a/community/py3-click/APKBUILD
+++ b/community/py3-click/APKBUILD
@@ -1,15 +1,19 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=py3-click
-pkgver=8.0.1
-pkgrel=0
+pkgver=8.1.7
+pkgrel=2
pkgdesc="Simple wrapper around optparse for powerful command line utilities"
url="https://click.palletsprojects.com"
arch="noarch"
license="BSD-3-Clause"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/c/click/click-$pkgver.tar.gz"
builddir="$srcdir/click-$pkgver"
@@ -17,17 +21,22 @@ replaces="py-click" # Backwards compatibility
provides="py-click=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD"/build/lib pytest -v tests
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-6a6d66c68dae4cfcfdab5d77dab4ab280b18f8e9ec326b4860012253d8f6b4fa57a5a3794ddebd228da85f893b0c6a737d8be3ad361d31098ef0a2ad684d6d0a click-8.0.1.tar.gz
+c67146ad0112daf8ed4db62a6b0a0065109332eb8fa31962ce40d61e27e2736020a0cadfebdd1656e2f23c20291b069d3a409faffe999a0907e6dbdef77aa014 click-8.1.7.tar.gz
"