aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cliff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cliff/APKBUILD')
-rw-r--r--community/py3-cliff/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/py3-cliff/APKBUILD b/community/py3-cliff/APKBUILD
index 0a38b3a2620..de97390bf97 100644
--- a/community/py3-cliff/APKBUILD
+++ b/community/py3-cliff/APKBUILD
@@ -1,41 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-cliff
-pkgver=3.9.0
-pkgrel=1
+pkgver=4.6.0
+pkgrel=0
pkgdesc="Command Line Interface Formulation Framework"
url="https://docs.openstack.org/cliff/latest/"
arch="noarch"
license="Apache-2.0"
depends="
+ py3-importlib-metadata
+ py3-stevedore
py3-yaml
- python3
"
makedepends="
+ py3-gpep517
py3-pbr
py3-setuptools
+ py3-wheel
"
checkdepends="
py3-pytest
py3-prettytable
py3-stevedore
"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/c/cliff/cliff-$pkgver.tar.gz"
options="!check" # Requires specific (old) version of py3-cmd2
builddir="$srcdir/cliff-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-04b33e14c3b29a02dc04855044184f934919ff92dbc09003f620083e5815597f8dee7201fa33019dd58a3e701d4c3f9966be1f4d23e019a881fee9a9bc1f0dbd cliff-3.9.0.tar.gz
+59e887eddbdf695927e9ece46749f3f62557fd20bb24d7ff109f174a4ae4886cb3b44994903522c1d31c83b9f7f101f16604f6ffc4167ed6405e49a09f236dd0 cliff-4.6.0.tar.gz
"