aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cliff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cliff/APKBUILD')
-rw-r--r--community/py3-cliff/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/py3-cliff/APKBUILD b/community/py3-cliff/APKBUILD
index c5f4d0aa795..3f729592206 100644
--- a/community/py3-cliff/APKBUILD
+++ b/community/py3-cliff/APKBUILD
@@ -1,41 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-cliff
-pkgver=3.8.0
-pkgrel=0
+pkgver=4.5.0
+pkgrel=1
pkgdesc="Command Line Interface Formulation Framework"
url="https://docs.openstack.org/cliff/latest/"
arch="noarch"
license="Apache-2.0"
depends="
+ py3-importlib-metadata
+ py3-stevedore
py3-yaml
- python3
"
makedepends="
+ py3-gpep517
py3-pbr
py3-setuptools
+ py3-wheel
"
checkdepends="
py3-pytest
py3-prettytable
py3-stevedore
"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/c/cliff/cliff-$pkgver.tar.gz"
options="!check" # Requires specific (old) version of py3-cmd2
builddir="$srcdir/cliff-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-002e3ddfb254c5369582cc28572856a8b4ad05d598a7f8aa690add69f49cabb12ef2ef17b6c1553792aaee785b7c1703b05dd9d4889271cd5eba5629fad3d09b cliff-3.8.0.tar.gz
+e32f5c6f53a37306e79de79d3be653ea9fbe8581da6162578048f17188bb48d82a8108bd118cf34712601b08f53be80287c33929e07993c7363b09ad4f076d33 cliff-4.5.0.tar.gz
"