aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cliff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cliff/APKBUILD')
-rw-r--r--community/py3-cliff/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/py3-cliff/APKBUILD b/community/py3-cliff/APKBUILD
index c4915dc682f..ada9ebbf2ee 100644
--- a/community/py3-cliff/APKBUILD
+++ b/community/py3-cliff/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-cliff
-pkgver=3.5.0
+pkgver=3.6.0
pkgrel=0
pkgdesc="Command Line Interface Formulation Framework"
url="https://docs.openstack.org/cliff/latest/"
@@ -16,6 +16,7 @@ makedepends="
py3-setuptools
"
checkdepends="
+ py3-pytest
py3-prettytable
py3-stevedore
"
@@ -28,11 +29,11 @@ build() {
}
check() {
- python3 setup.py test
+ pytest
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="215f22e5dd2c4c17bd0f19866189b6b247377a7d5bddeb4a07b7536af7545bd0440b5fb0a98474fc018e3b12f6695f60028c012f3e7eeb6498b20f2923939d08 cliff-3.5.0.tar.gz"
+sha512sums="ed4077e8b9e848dbd8aebb076b9f55086ea861cbf22322f7c9fb03a66b88bd60f5c09c6914481fe5f02bad25c0183e245405d9ac54d37b6bf0f14c9c97bd7684 cliff-3.6.0.tar.gz"