aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cliff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cliff/APKBUILD')
-rw-r--r--community/py3-cliff/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/community/py3-cliff/APKBUILD b/community/py3-cliff/APKBUILD
index 9136419aef3..c4915dc682f 100644
--- a/community/py3-cliff/APKBUILD
+++ b/community/py3-cliff/APKBUILD
@@ -1,15 +1,24 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-cliff
-pkgver=3.4.0
+pkgver=3.5.0
pkgrel=0
pkgdesc="Command Line Interface Formulation Framework"
url="https://docs.openstack.org/cliff/latest/"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-yaml"
-makedepends="py3-setuptools py3-pbr"
-checkdepends="py3-stevedore py3-prettytable"
+depends="
+ py3-yaml
+ python3
+ "
+makedepends="
+ py3-pbr
+ py3-setuptools
+ "
+checkdepends="
+ py3-prettytable
+ py3-stevedore
+ "
source="https://pypi.python.org/packages/source/c/cliff/cliff-$pkgver.tar.gz"
options="!check" # Requires specific (old) version of py3-cmd2
builddir="$srcdir/cliff-$pkgver"
@@ -26,4 +35,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="d625588f4eed0aeee549b4a21e604f1cb886b8c10a12df7c546a5292223ec5bf9067352b4d326d5710673dab56eec47e2fb46c9c5d5df6e9fbf026d030bcde1c cliff-3.4.0.tar.gz"
+sha512sums="215f22e5dd2c4c17bd0f19866189b6b247377a7d5bddeb4a07b7536af7545bd0440b5fb0a98474fc018e3b12f6695f60028c012f3e7eeb6498b20f2923939d08 cliff-3.5.0.tar.gz"