aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cmake-build-extension/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cmake-build-extension/APKBUILD')
-rw-r--r--community/py3-cmake-build-extension/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-cmake-build-extension/APKBUILD b/community/py3-cmake-build-extension/APKBUILD
new file mode 100644
index 00000000000..9dc3c031cc0
--- /dev/null
+++ b/community/py3-cmake-build-extension/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer:
+pkgname=py3-cmake-build-extension
+pkgver=0.5.1
+pkgrel=5
+pkgdesc="Setuptools extension to build and package CMake projects"
+url="https://github.com/diegoferigo/cmake-build-extension"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools_scm
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/diegoferigo/cmake-build-extension/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/cmake-build-extension-$pkgver"
+options="!check" # no tests
+
+build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+df7b215287607bab95607126bc903d3cdabcca19d29951accfc2e3a77ee4b20b3b599f9ea15380684fb569311f4295aabcc7cfdc46cd504a39ec77594df6c722 py3-cmake-build-extension-0.5.1.tar.gz
+"