aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-colorclass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-colorclass/APKBUILD')
-rw-r--r--community/py3-colorclass/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/community/py3-colorclass/APKBUILD b/community/py3-colorclass/APKBUILD
index 157b46b537f..5dc40412b4a 100644
--- a/community/py3-colorclass/APKBUILD
+++ b/community/py3-colorclass/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-colorclass
-pkgver=2.2.0
-pkgrel=0
+pkgver=2.2.2
+pkgrel=4
pkgdesc="Colorful worry-free console applications"
-url="https://github.com/Robpol86/colorclass"
+url="https://github.com/matthewdeanmartin/colorclass"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/c/colorclass/colorclass-$pkgver.tar.gz
- python3.9.patch"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/c/colorclass/colorclass-$pkgver.tar.gz"
options="!check" #tests are in the github archive not pypi archive
builddir="$srcdir/colorclass-$pkgver"
@@ -19,10 +19,9 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-8e6be012b7671edfdd1723a64964e200b3617fd38545a46267eeb98d29133cb71016ee5a6d0ce98df86904467fb9df742dd612f7df33682cec11c81d5d51aa1b colorclass-2.2.0.tar.gz
-b2f7331b1f5e30205d52ec468e10ca32fe1aa8f6fdfeff0877434a13ddd017e90bc934b154922d472356805a7bd53e892e2f947718371919caa519ac2bf057da python3.9.patch
+18d3f403254043d85db61fac1d6faf2a1fcdfd4233d268889b9fa08698d21d77732376b1ef1b88854ba80c810bf74853a652de3c98871a9d6d69638027b81719 colorclass-2.2.2.tar.gz
"