aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-colorclass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-colorclass/APKBUILD')
-rw-r--r--community/py3-colorclass/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-colorclass/APKBUILD b/community/py3-colorclass/APKBUILD
new file mode 100644
index 00000000000..5dc40412b4a
--- /dev/null
+++ b/community/py3-colorclass/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=py3-colorclass
+pkgver=2.2.2
+pkgrel=4
+pkgdesc="Colorful worry-free console applications"
+url="https://github.com/matthewdeanmartin/colorclass"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/c/colorclass/colorclass-$pkgver.tar.gz"
+options="!check" #tests are in the github archive not pypi archive
+builddir="$srcdir/colorclass-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+18d3f403254043d85db61fac1d6faf2a1fcdfd4233d268889b9fa08698d21d77732376b1ef1b88854ba80c810bf74853a652de3c98871a9d6d69638027b81719 colorclass-2.2.2.tar.gz
+"