aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-colorzero/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-colorzero/APKBUILD')
-rw-r--r--community/py3-colorzero/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-colorzero/APKBUILD b/community/py3-colorzero/APKBUILD
new file mode 100644
index 00000000000..0a6c0900ee3
--- /dev/null
+++ b/community/py3-colorzero/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
+pkgname=py3-colorzero
+pkgver=2.0
+pkgrel=4
+pkgdesc="Another color manipulation library for Python"
+url="https://colorzero.readthedocs.io/"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="py3-setuptools py3-gpep517 py3-installer py3-wheel"
+checkdepends="py3-pytest py3-pytest-cov"
+subpackages="$pkgname-pyc"
+source="https://github.com/waveform80/colorzero/archive/refs/tags/release-$pkgver/py3-colorzero-$pkgver.tar.gz"
+builddir="$srcdir/colorzero-release-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+55c507e4ceeff9feb00db570f50c782d68e59cb84fbf5f2501c1e0d23017e55b854e8ff6ab62424e331afa13317cc87695384292b8485fab780094c6784001bc py3-colorzero-2.0.tar.gz
+"