aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-confuse/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-confuse/APKBUILD')
-rw-r--r--community/py3-confuse/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/py3-confuse/APKBUILD b/community/py3-confuse/APKBUILD
new file mode 100644
index 00000000000..7abc6c5c5da
--- /dev/null
+++ b/community/py3-confuse/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Marvin Preuss <marvin@xsteadfastx.org>
+# Maintainer: Marvin Preuss <marvin@xsteadfastx.org>
+pkgname=py3-confuse
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Painless YAML config files for Python"
+url="https://github.com/beetbox/confuse"
+arch="noarch"
+license="MIT"
+depends="python3 py3-yaml"
+makedepends="py3-gpep517 py3-flit-core py3-installer"
+checkdepends="py3-nose"
+subpackages="$pkgname-pyc"
+source="confuse-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/confuse/confuse-$pkgver.tar.gz"
+builddir="$srcdir/confuse-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ nosetests
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/confuse*.whl
+}
+
+sha512sums="
+fe9e17d3b321079290fa2c7db64cd5664db11f1277fe608cf5a1419254b83eee9bc169e34631a429ab1bf47779ea709156b8310a97e65fae32a20802b379fa76 confuse-2.0.1.tar.gz
+"