aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cryptography/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cryptography/APKBUILD')
-rw-r--r--community/py3-cryptography/APKBUILD69
1 files changed, 48 insertions, 21 deletions
diff --git a/community/py3-cryptography/APKBUILD b/community/py3-cryptography/APKBUILD
index d5c400883db..d5fffe7cd8f 100644
--- a/community/py3-cryptography/APKBUILD
+++ b/community/py3-cryptography/APKBUILD
@@ -1,54 +1,81 @@
# Contributor: August Klein <amatcoder@gmail.com>
-# Maintainer: August Klein <amatcoder@gmail.com>
-
-# RESTRICTED: Any upgrade to this package must be tested against ALL architectures
-# supported by Alpine. It is not allowed to mask this package on ANY architecture.
-# At present, upgrade is not allowed because rustc is not yet available on ALL
-# supported architectures. Any upgrade which masks an architecture WILL be reverted.
-
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-cryptography
-_pyname=cryptography
-pkgver=3.4.8
+pkgver=42.0.5
pkgrel=1
pkgdesc="Cryptographic recipes and primitives for Python"
url="https://cryptography.io/"
arch="all"
license="Apache-2.0 OR BSD-3-Clause"
-depends="python3 py3-cffi py3-idna py3-six"
-makedepends="python3-dev py3-setuptools libffi-dev openssl1.1-compat-dev"
-checkdepends="py3-pytest py3-pytest-subtests py3-hypothesis py3-tz py3-pretend py3-iso8601"
+depends="python3 py3-cffi"
+makedepends="
+ libffi-dev
+ openssl-dev>3
+ py3-flit-core
+ py3-gpep517
+ py3-setuptools
+ py3-setuptools-rust
+ py3-wheel
+ python3-dev
+ "
+checkdepends="
+ py3-certifi
+ py3-hypothesis
+ py3-iso8601
+ py3-pretend
+ py3-pytest
+ py3-pytest-benchmark
+ py3-pytest-subtests
+ py3-pytest-xdist
+ py3-tz
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-$pkgver.tar.gz
https://files.pythonhosted.org/packages/source/c/cryptography_vectors/cryptography_vectors-$pkgver.tar.gz
- no-rust.patch"
-builddir="$srcdir/$_pyname-$pkgver"
+ skip-aead-tests-on-32-bit.patch
+ "
+builddir="$srcdir/cryptography-$pkgver"
+options="net"
replaces="py-cryptography" # Backwards compatibility
provides="py-cryptography=$pkgver-r$pkgrel" # Backwards compatibility
# secfixes:
+# 41.0.2-r0:
+# - CVE-2023-38325
+# 39.0.1-r0:
+# - CVE-2023-23931
# 3.2.2-r0:
# - CVE-2020-36242
# 3.2.1-r0:
# - CVE-2020-25659
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
# prepare cryptography vectors for testing
cd "$srcdir/cryptography_vectors-$pkgver"
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$(echo $PWD/build/lib.linux-*):$srcdir/cryptography_vectors-$pkgver/build/lib" pytest
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/cryptography*.whl
+ test-env/bin/python3 -m installer "$srcdir"/cryptography_vectors-$pkgver/.dist/cryptography*.whl
+ test-env/bin/python3 -m pytest -n $JOBS
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" \
+ .dist/cryptography-*.whl
}
sha512sums="
-b0d64a573b488af3e453fc1885bbafb65f8a2260e81cf64830f981589afca0bd7be052a5f5b8ed83dd78d9638da37c680f3705cbf2d47d5b28fb5a5454f1cea5 cryptography-3.4.8.tar.gz
-de668cc0599862f32993022dead7fd682cd6b9a458d00a71c810a2904bc6d5482b8f5544b174b9e34a3f13a126b7c957942d0159a13c0a0676e702cf87c49071 cryptography_vectors-3.4.8.tar.gz
-23eb7ec9e9804ed08d2a2942a60b91f07d12bd36c699afd4f0ae0ab5c795a1b55827c50631850ebdf126b1752ed1ab41ac3da85fa49a080d4c27b4caa2134619 no-rust.patch
+5524fd230b55580a2c647a0a78197a783e201fdfa8b3177b72c6d7b689afd76a689e4fe3593120d3adb7ee5cc4adf9211e8deedc8fab355e9ed70076db09f68b cryptography-42.0.5.tar.gz
+38af39f8cb869af630d4b75d7a62ba9778fd59ceee2858504655d9065a82d2365644c9ab301c90f3ebd9f32f2e04867650b6d392c1f2b6880e3bb0c216e6a419 cryptography_vectors-42.0.5.tar.gz
+670ecc2d95083186bf7e986b18093ac289c218e7ab77b54258e21d09fd5729f551cf876645f2a175086c1a089926a367426d7745ef406efc3d1d82286d454323 skip-aead-tests-on-32-bit.patch
"