aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cu2qu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cu2qu/APKBUILD')
-rw-r--r--community/py3-cu2qu/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/community/py3-cu2qu/APKBUILD b/community/py3-cu2qu/APKBUILD
index ee20c05eb98..82bcc8c9547 100644
--- a/community/py3-cu2qu/APKBUILD
+++ b/community/py3-cu2qu/APKBUILD
@@ -1,30 +1,35 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-cu2qu
pkgver=1.6.7
-pkgrel=2
+pkgrel=8
pkgdesc="Cubic-to-quadratic bezier curve conversion"
url="https://github.com/googlefonts/cu2qu"
arch="all"
license="Apache-2.0"
-depends="python3 py3-fonttools py3-defcon"
+depends="python3 py3-fonttools py3-fs"
makedepends="py3-setuptools py3-setuptools_scm python3-dev cython"
-checkdepends="py3-pytest py3-coverage py3-pytest-runner"
+checkdepends="py3-pytest py3-coverage py3-defcon py3-pytest-runner"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/googlefonts/cu2qu/archive/v$pkgver.tar.gz"
builddir="$srcdir/cu2qu-$pkgver"
+options="!check" # fail with py3.11
build() {
- git init
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
export CU2QU_WITH_CYTHON=1
python3 setup.py build
}
check() {
- python3 setup.py test
+ PYTHONPATH="$(echo build/lib.linux*)" \
+ pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="5140db9fad305942a45faa405a70bcee389b03257889b82faa4704c8250c27c81273d28fa859701b4d05c439673887f07960f225563eb651bf5a8a93f7743b05 py3-cu2qu-1.6.7.tar.gz"
+sha512sums="
+5140db9fad305942a45faa405a70bcee389b03257889b82faa4704c8250c27c81273d28fa859701b4d05c439673887f07960f225563eb651bf5a8a93f7743b05 py3-cu2qu-1.6.7.tar.gz
+"