aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cx_freeze/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-cx_freeze/APKBUILD')
-rw-r--r--community/py3-cx_freeze/APKBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/community/py3-cx_freeze/APKBUILD b/community/py3-cx_freeze/APKBUILD
index 633d167900d..bb050c44e89 100644
--- a/community/py3-cx_freeze/APKBUILD
+++ b/community/py3-cx_freeze/APKBUILD
@@ -2,40 +2,36 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-cx_freeze
_pkgname=cx_Freeze
-pkgver=6.10
+pkgver=6.15.16
pkgrel=1
pkgdesc="Set of utilities for freezing Python scripts into executables"
url="https://github.com/marcelotduarte/cx_Freeze"
arch="all !ppc64le"
-license="PSF"
+license="PSF-2.0"
depends="patchelf"
-makedepends="py3-setuptools python3-dev"
+makedepends="py3-gpep517 py3-setuptools python3-dev py3-wheel"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/marcelotduarte/cx_Freeze/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+options="!check" # todo
prepare() {
default_prepare
- # fix permissions, which are 0700 for files and 2700 for directories
- find "$builddir" -type f -exec chmod 0644 {} \;
- find "$builddir" -type d -exec chmod 0755 {} \;
-
- sed -i '/patchelf/c\#' "$builddir/setup.cfg"
sed -i 's/DESTSHARED/DESTLIB/' "$builddir/cx_Freeze/freezer.py"
}
build() {
- python3 setup.py build
-}
-
-check() {
- python3 setup.py check
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --skip-build --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-432e899f1897ad237e231fbbc38f8dca0aedd1bb4215bcab3ea06f7a937f391df69d35fe5034f5eecd47b6d577612355a78f3c01536c262562de6b2a5ee3d473 py3-cx_freeze-6.10.tar.gz
+9bc6ffd3741099fe14afa1fdafb9deee647737e31de6be8e61411cd0628952c05593f15dea47247b6f778caa02d60f89f0541967e63361f5f550c087891b3fb2 py3-cx_freeze-6.15.16.tar.gz
"