aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-daphne/0001-pytest-runner-extra.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-daphne/0001-pytest-runner-extra.patch')
-rw-r--r--community/py3-daphne/0001-pytest-runner-extra.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/community/py3-daphne/0001-pytest-runner-extra.patch b/community/py3-daphne/0001-pytest-runner-extra.patch
new file mode 100644
index 00000000000..7cbb141aaa2
--- /dev/null
+++ b/community/py3-daphne/0001-pytest-runner-extra.patch
@@ -0,0 +1,14 @@
+diff --git a/setup.py b/setup.py
+index ae19f5d..636c5d5 100755
+--- a/setup.py
++++ b/setup.py
+@@ -24,8 +24,7 @@ setup(
+ include_package_data=True,
+ install_requires=["twisted[tls]>=22.4", "autobahn>=22.4.2", "asgiref>=3.5.2,<4"],
+ python_requires=">=3.7",
+- setup_requires=["pytest-runner"],
+- extras_require={"tests": ["hypothesis", "pytest", "pytest-asyncio", "django"]},
++ extras_require={"tests": ["pytest-runner","hypothesis", "pytest", "pytest-asyncio", "django"]},
+ entry_points={
+ "console_scripts": ["daphne = daphne.cli:CommandLineInterface.entrypoint"]
+ },