aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-decopatch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-decopatch/APKBUILD')
-rw-r--r--community/py3-decopatch/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/py3-decopatch/APKBUILD b/community/py3-decopatch/APKBUILD
new file mode 100644
index 00000000000..f69e8dcc50f
--- /dev/null
+++ b/community/py3-decopatch/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Andy Hawkins <andy@gently.org.uk>
+# Maintainer: Andy Hawkins <andy@gently.org.uk>
+pkgname=py3-decopatch
+pkgver=1.4.10
+pkgrel=4
+pkgdesc="Python decorators made easy"
+url="https://github.com/smarie/python-decopatch"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ py3-makefun
+ "
+makedepends="
+ py3-gpep517
+ py3-pytest-runner
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/d/decopatch/decopatch-$pkgver.tar.gz"
+builddir="$srcdir/decopatch-$pkgver"
+options="!check" # Test suite requires pytest-cases, which depends on this package
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/decopatch-$pkgver*-py2.py3-none-any.whl
+}
+
+sha512sums="
+7554c5bdef6aeb06968334c8aef3f67b56bd3ff8be5e05cb6289f3088848d946d46ecc1d9f73bab9db80b6981aa4f9039c359eb8a0fe9f4acee62addf4f0ed96 decopatch-1.4.10.tar.gz
+"