aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-defcon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-defcon/APKBUILD')
-rw-r--r--community/py3-defcon/APKBUILD33
1 files changed, 23 insertions, 10 deletions
diff --git a/community/py3-defcon/APKBUILD b/community/py3-defcon/APKBUILD
index 2d9ccbb9a13..1dd286eee88 100644
--- a/community/py3-defcon/APKBUILD
+++ b/community/py3-defcon/APKBUILD
@@ -1,25 +1,38 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-defcon
-pkgver=0.7.2
-pkgrel=0
+pkgver=0.10.3
+pkgrel=1
pkgdesc="Flexible objects for represnting UFO data"
options="!check" # Requires unpackaged FontPens
-url="https://pypi.org/project/defcon/"
+url="https://github.com/robotools/defcon"
arch="noarch"
license="MIT"
-depends="python3 py3-fonttools"
-makedepends="py3-setuptools"
-source="https://pypi.org/packages/source/d/defcon/defcon-$pkgver.zip"
+depends="python3 py3-fonttools py3-fs py3-unicodedata2"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/robotools/defcon/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/defcon-$pkgver"
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/defcon-*.whl
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/defcon/test
}
-sha512sums="3cd74b070fdaf5cc099db8fe005070db2f4872b5a26aee03fc9de723793e3428d8100e30e3de035027541dd4b7815f36ba57b7143d44805005e0e482310d3771 defcon-0.7.2.zip"
+sha512sums="
+ac74d14be194bde4cf10e7355959038b229af50e4731dd46cc28ab7f44fdcc84114da4c3300d5411efada9e3971d3a923835d49b1f20049a36935ac4df8e0e90 py3-defcon-0.10.3.tar.gz
+"