aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-defusedxml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-defusedxml/APKBUILD')
-rw-r--r--community/py3-defusedxml/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/py3-defusedxml/APKBUILD b/community/py3-defusedxml/APKBUILD
index 0b0988b940f..5030d82aa2b 100644
--- a/community/py3-defusedxml/APKBUILD
+++ b/community/py3-defusedxml/APKBUILD
@@ -3,13 +3,14 @@
pkgname=py3-defusedxml
_pkgname=defusedxml
pkgver=0.7.1
-pkgrel=1
+pkgrel=5
pkgdesc="XML bomb protection for Python stdlib modules"
url="https://github.com/tiran/defusedxml"
arch="noarch"
license="Python-2.0"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/tiran/defusedxml/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -17,15 +18,15 @@ replaces=py-defusedxml # Backwards compatibility
provides=py-defusedxml=$pkgver-r$pkgrel # Backwards compatibility
build() {
- python3 setup.py build
+ python3 setup.py build
}
check() {
- python3 setup.py test
+ python3 setup.py test
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="4f536794b814291520c7db27765014c57f415554cff569cddab596b33e1aa03799aae9448fdaf07417d1a9f4d8782aa827d1b68aac6881ffe5c2ca9b8a40d864 py3-defusedxml-0.7.1.tar.gz"