aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-dicttoxml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-dicttoxml/APKBUILD')
-rw-r--r--community/py3-dicttoxml/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/community/py3-dicttoxml/APKBUILD b/community/py3-dicttoxml/APKBUILD
index 5f91d3b263e..7a9feb2213c 100644
--- a/community/py3-dicttoxml/APKBUILD
+++ b/community/py3-dicttoxml/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-dicttoxml
_pkgname=dicttoxml
-pkgver=1.7.4
-pkgrel=5
+pkgver=1.7.16
+pkgrel=3
pkgdesc="Converts a Python dictionary or other native data type into a valid XML string"
url="https://github.com/quandyfactory/dicttoxml"
arch="noarch"
license="GPL-2.0-only"
-depends="python3"
+depends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
options="!check" # No test suite
@@ -17,11 +18,16 @@ replaces=py-dicttoxml # Backwards compatibility
provides=py-dicttoxml=$pkgver-r$pkgrel # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="91abcf2b9b248717618e9fc1c8694e881b9deaa16438dd4674f94a22b4aabfdab3b13f95c3d44a60577d49eca82fb268f59b33d1312cf5388bdaf949a2865cbf dicttoxml-1.7.4.tar.gz"
+sha512sums="
+ac9d5b0f8acd0a18f918309cacba131843feebd6ad7c94935062d6e1ed7b529c5b91d6a9b65787647f73616e974d0599e8515bb07d69b036483d3a733e4dec6a dicttoxml-1.7.16.tar.gz
+"