aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-distributed/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-distributed/APKBUILD')
-rw-r--r--community/py3-distributed/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/community/py3-distributed/APKBUILD b/community/py3-distributed/APKBUILD
new file mode 100644
index 00000000000..b5ea4e500d7
--- /dev/null
+++ b/community/py3-distributed/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-distributed
+pkgver=2024.4.1
+pkgrel=0
+pkgdesc="A library for distributed computation"
+url="https://distributed.dask.org/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ py3-click
+ py3-cloudpickle
+ py3-dask
+ py3-jinja2
+ py3-locket
+ py3-msgpack
+ py3-psutil
+ py3-sortedcontainers
+ py3-tblib
+ py3-toolz
+ py3-tornado
+ py3-urllib3
+ py3-yaml
+ py3-zict
+ "
+makedepends="
+ linux-headers
+ py3-gpep517
+ py3-python-versioneer
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ yaml-dev
+ "
+checkdepends="
+ py3-arrow
+ py3-h5py
+ py3-jsonschema
+ py3-lz4
+ py3-paramiko
+ py3-pytest
+ py3-pytest-asyncio
+ py3-requests
+ py3-scipy
+ "
+subpackages="$pkgname-pyc"
+source="https://pypi.python.org/packages/source/d/distributed/distributed-$pkgver.tar.gz"
+builddir="$srcdir/distributed-$pkgver"
+options="!check" # py3-dask circular dependency
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+09405b3a76bf09f098475be98c8617857f984df6c1f3e620a8ee441008ef660e81200d0ce06078e057edcd202098f9541f500dc70f03d50511978667f58116b6 distributed-2024.4.1.tar.gz
+"