aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-distributed/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-distributed/APKBUILD')
-rw-r--r--community/py3-distributed/APKBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/community/py3-distributed/APKBUILD b/community/py3-distributed/APKBUILD
index d98deccfb4b..b5ea4e500d7 100644
--- a/community/py3-distributed/APKBUILD
+++ b/community/py3-distributed/APKBUILD
@@ -1,28 +1,34 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-distributed
-pkgver=2022.2.0
+pkgver=2024.4.1
pkgrel=0
pkgdesc="A library for distributed computation"
url="https://distributed.dask.org/"
arch="noarch"
license="BSD-3-Clause"
-depends="python3"
depends="
py3-click
py3-cloudpickle
py3-dask
+ py3-jinja2
+ py3-locket
py3-msgpack
py3-psutil
py3-sortedcontainers
py3-tblib
+ py3-toolz
py3-tornado
+ py3-urllib3
py3-yaml
py3-zict
"
makedepends="
linux-headers
+ py3-gpep517
+ py3-python-versioneer
py3-setuptools
+ py3-wheel
python3-dev
yaml-dev
"
@@ -37,26 +43,28 @@ checkdepends="
py3-requests
py3-scipy
"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/d/distributed/distributed-$pkgver.tar.gz"
-# Mosts tests are broken by new pytest-asyncio
-# See https://github.com/dask/distributed/pull/4212 for an explanation
-options="!check"
builddir="$srcdir/distributed-$pkgver"
+options="!check" # py3-dask circular dependency
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" pytest \
- --ignore distributed/comm/tests/test_comms.py \
- --ignore distributed/tests/test_core.py
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-652064a66864110e20bfc1258f7f2fb04e76e70bd444eb13831f139288dd7e200f278f10908d52f1d1975cf8cc857db456cca1a3e2f8a04b81dea1ffe7860cc3 distributed-2022.2.0.tar.gz
+09405b3a76bf09f098475be98c8617857f984df6c1f3e620a8ee441008ef660e81200d0ce06078e057edcd202098f9541f500dc70f03d50511978667f58116b6 distributed-2024.4.1.tar.gz
"