aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-distributed/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-distributed/APKBUILD')
-rw-r--r--community/py3-distributed/APKBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/community/py3-distributed/APKBUILD b/community/py3-distributed/APKBUILD
index c84164c500d..b5ea4e500d7 100644
--- a/community/py3-distributed/APKBUILD
+++ b/community/py3-distributed/APKBUILD
@@ -1,28 +1,34 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-distributed
-pkgver=2.30.1
+pkgver=2024.4.1
pkgrel=0
pkgdesc="A library for distributed computation"
url="https://distributed.dask.org/"
-arch="noarch !mips !mips64 !s390x" # Blocked by py3-dask
+arch="noarch"
license="BSD-3-Clause"
-depends="python3"
depends="
py3-click
py3-cloudpickle
py3-dask
+ py3-jinja2
+ py3-locket
py3-msgpack
py3-psutil
py3-sortedcontainers
py3-tblib
+ py3-toolz
py3-tornado
+ py3-urllib3
py3-yaml
py3-zict
"
makedepends="
linux-headers
+ py3-gpep517
+ py3-python-versioneer
py3-setuptools
+ py3-wheel
python3-dev
yaml-dev
"
@@ -37,22 +43,28 @@ checkdepends="
py3-requests
py3-scipy
"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/d/distributed/distributed-$pkgver.tar.gz"
-# Tests require ipv6 stack which might not always be available yet
-# Net required for tests
-options="!check"
builddir="$srcdir/distributed-$pkgver"
+options="!check" # py3-dask circular dependency
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$PWD/build/lib" pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="91bd99ebc5030c1a5629053362a27fbded0dc75ad7a113ab7f6581b0d6b7a6aac270ef2c86d7901ac18b2cf324394e280be4e1dd3f601aaf26c9cab5e6edbc0b distributed-2.30.1.tar.gz"
+sha512sums="
+09405b3a76bf09f098475be98c8617857f984df6c1f3e620a8ee441008ef660e81200d0ce06078e057edcd202098f9541f500dc70f03d50511978667f58116b6 distributed-2024.4.1.tar.gz
+"